当前位置:首页 > 问答

一根均线金叉共振选股

我来帮TA回答

怎么编写均线量能MACD金叉共振选股公式

MACD指标的金叉和死叉一般准确率不高,但都还是有用的,而我们常用MACD指标的背离来判断股价的涨跌,还能捕捉到每段行情的最高点和最低点,准确率非常高。下面就是运用MACD指标背离技巧的方法:MACD背离: 1、MACD的背离,据我所知,有三种判定法。一是看它的波峰波谷,二是看它的红柱绿柱,三是看它的金叉点死叉点。这是不矛盾的。以6124附近的MACD日线为例,6124点创出新高后,一方面,DIFF的两个波峰却是平的,而DEA是一波比一波低;另一方面,9月7日的死叉点DIFF的值是217,10月19日的死叉点是205。从任何一面来看,均是顶背离,都应该果断抛售。(写到这,不免一声长叹,当时的我太莽撞了,就这么两眼一抹黑的就进来了。如果早学了技术,怎么会赔得这么惨?) 2、MACD的顶背离比底背离可靠。顶背离只要发出一次信号,就应该行动了,但是底背离却通常要再等一等。以大盘60分MACD为例,1月29日的底背离并没有彻底反转,而是等到了2月1日的那一个底背离才迎来有史以来最大的一个涨幅。 3、短周期MACD和长周期MACD的矛盾。常常会发生这样的情况:60分MACD顶背离,而日线却是很健康的一波比一波高。这时,要看当时是单边上升市还是振荡市。30分和60分图MACD发出的顶背离信号比较频繁,在单边上升市,可能会更错过后面更大的行情,但是在振荡市中,却可以逃过一劫。以1月15日的5500点为例,MACD日线的毛刺全都被平滑掉了,看不出背离状态,但是在60分图中,却是个清清楚楚的顶背离。 4、MACD顶背离陷阱。有时候,MACD顶背离了,股价却蹿上去了。以000511为例:MACD日线1月4日和1月25日两处是个明显的顶背离,30分钟线2月13与2月15日也是顶背离,但是2月18日周一开盘就封住了涨停。这种时候,就要观察成交量了,如果成交量很大,说明顶背离被突破了,后面还有行情,如果成交量没有创出新高,还是不参与为好。对新手来说,我认为只要看到MACD顶背离了,即使不清仓,也应该适当减仓回避风险,因为这是我们目前唯一看得清的东西,自己看不明白的钱,先不急着挣。 MACD背离的判断应该与双底、双顶、头肩顶、头肩底等相互配合才会有更加高的可靠性,用MACD背离要灵活与K线相互配合,呵呵 原文链接:http://www.55188.com/viewthread.php?tid=2424357

请教老师帮忙编辑个通达信日线,60,30分钟MACD金叉共振选股公式,谢谢了

不需要编制 通达信自带呀
你只要按照如下步骤操作
选股器/条件选股/条件选股公式/macd买入条件选股/选择周期中选日线/加入条件/选择周期中选60分钟线/加入条件/选择周期中选30分钟线/加入条件/执行选股

请编写一个均线金叉,量线金叉的选股公式通达信用

条件1
XG:CROSS(MA(C,5),MA(C,10));
条件2
XG:CROSS(MA(V,5),MA(V,10));
如果要合用,即:
XG:CROSS(MA(C,5),MA(C,10)) AND CROSS(MA(V,5),MA(V,10));

如何根据均线选股

只用均线不行

求通达信macd,kdj金叉共振

这个只是作为这个一个技术指标这块的要求这块,看取值

通达信MACD KDJ金叉共振的公式,满意答案一定重赏。

公式不是万能的,但没有公式可万万不能,主要是自己。
DIF:(EMA(CLOSE,12)-EMA(CLOSE,26))*100;
DEA:EMA(DIF,9);
MACD:(DIF-DEA)*2,COLORSTICK;
DRAWICON(CROSS(DIF,DEA),DEA,1);
DRAWICON(CROSS(DEA,DIF),DEA,2);
IF(DIF<DEA,DIF,DRAWNULL),COLORGREEN;
DD:=C=HHV(C,180);
EE:=DEA<
REF(DEA,1)
AND
REF(DEA<
REF(DEA,1),1)=1;
CC:=C>
REF(C,1)
AND
REF(C>
REF(C,1),1)=1;
顶背离:=(DD
AND
EE
AND
DEA<
HHV(DEA,180))*DEA;
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
{顶背:=REF(CLOSE,A2+1)<CLOSE
AND
REF(DIF,A2+1)>DIF
AND
CROSS(DEA,DIF);}
DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORRED,LINETHICK2;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,9,3),COLORYELLOW;
D:SMA(K,9,3),COLORWHITE;
J:3*K-2*D,COLORMAGENTA;
IF(J<D,J,DRAWNULL),COLORFFEE44;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
B1:=REF(C,A1+1)>C
AND
REF(DIF,A1+1)<DIF
AND
CROSS(DIF,DEA);
A22:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A22+1)>C
AND
REF("KDJ.K"(9,3,3),A22+1)<"KDJ.K"(9,3,3)
AND
CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C
AND
REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24)
AND
CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
DRAWTEXT(B1,DEA-0.20,'▲MACD底背'),COLORWHITE;
DRAWTEXT(B2,D-0.20,'●KDJ底背'),COLORFF00FF;
{DJ:=CROSS(J,D)
AND
D<20;DRAWTEXT(DJ,J-0.3,'低金叉'),COLORCYAN;MDJ:=CROSS(DIF,DEA)
AND
DEA<0;DRAWTEXT(MDJ,DEA-0.3,'低金叉'),COLORGREEN;DRAWTEXT(CROSS(DEA,DIF),DIF+0.3,'死叉'),COLORYELLOW;DRAWTEXT(CROSS(D,J),J+0.3,'死叉'),COLORRED;}
A:=CROSS(DIF,DEA)
AND
CROSS(K,D)
AND
CROSS(J,D);
DRAWICON(A,LOW*0.98,1);
B4:CROSS(DIF,DEA)
AND
CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
DRAWTEXT(B4,L-0.20,'★金叉共振'),COLOR0099FF;
DRAWICON(CROSS(K,D),D,1);
DRAWICON(CROSS(D,K),D,2);
BA:=DEA>REF(DEA,1);
BB:=SUM(BA,5)>=4;
BC:=C<O;
BD:=SUM(BC,5)>=2;
BXG:FILTER(BB
AND
BD
AND
J>REF(J,1)
AND
REF(J,1)<REF(J,2),3);
STICKLINE(BXG,HHV(J,60),HHV(J,60)-20,1,0),COLORRED;
SS:=EMA(C,11);
LL:=(EMA(C,1)+EMA(C,2)+EMA(C,3)+EMA(C,5))/4;
{短:EMA(LL,2),COLORGREEN,LINETHICK2;}
{长:EMA(SS,2),COLORMAGENTA,LINETHICK2;}
AA:=(C-LLV(C,10))/(HHV(C,10)-LLV(C,10));
(CROSS(AA,0.05)-1);